Cambiar la version de php de OSX

0
659

Como cambiar el php de osx:

Cuando desarrollamos, generalmente todas las extensiones que usamos están instaladas en nuestro MAMP y no necesariamente en el PHP que viene por default en OSX.Uno de los problemas más comunes es que cuando intentamos usar algunos framewoks como laravel o composer nos responde que no tiene instalada la extención Mcrypt,pero MAMP si la tiene y nos cuestionamos como poder usar el php de MAMP para usar composer.

Esto lo podemos resolver con un symlink:

Los enlaces simbólicos son también accesos directos, pero con algunas diferencias.La principal de estas es que una modificación en el enlace simbólico se verá reflejada en el archivo o carpeta original a la que apunta. En otras palabras,un enlace simbólico sería una forma de tener una copia de un archivo o carpeta en otra ubicación sin duplicar espacio.

Primero vamos a la ruta /usr/bin/, para esto tecleamos (cmd +Shift + G) copiamos la ruta y damos click en “Go”.

cambiar-php-de-osx-1

Ahora re-nombramos el archivo “php” que deberá de quedar así “php_”

cambiar-php-de-osx-2

Abrimos “Terminal”, y ejecutamos el siguiente comando.Con esto se creara un symlink de php de Mamp

$ sudo ln -s /Applications/MAMP/bin/php/php5.4.10/bin/php /usr/bin/php

cambiar-php-de-osx-3

Con esto, ya podemos usar la version de php con la libreria Mcrypt.

cambiar-php-de-osx-4




Dejar respuesta